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TUTORIAL 1.

C-WIZARD RESISTANCE

1.1 INTRODUCTION

1.1.1 Problem Description

Ship hull performance calculations have become a classical procedure for marine CFD
computations. Decreasing the time of the complete simulation setup would simplify the procedure
for computations and provide quick and easy hull performance estimation as well as the resistance
curve for a particular hull. C-Wizard mode is introduced into FINE™/Marine software for these
purposes.

A full scale resistance computation for the KCS model is performed with the following settings:

l Reference length (Lpp): 230m;

l Velocity: 12, 18 and 24 kt; Froude numbers between 0.13 and 0.26

l Draft of 9m in the full scale ship frame of reference;

l Water density: 1026.021kg/m³;

l Kinematic viscosity: 1.19e-6m²/s.

1.1.2 Objectives

The goal of this tutorial is to provide step-by-step instructions for the C-Wizard mode resistance
calculation setup including additional numerical and flow parameters: Adaptive grid refinement,
actuator disk and external forces. The widely investigated full scale container ship (KCS) hull is
employed here for computation performance.

The tutorial gives best practices on the C-Wizard mode computation and mesh setup, giving the
flow and mesh settings details information. Indeed, parameters are imposed automatically by the
C-Wizard where the minimal user input is required. Geometry patches merging recommendations
are developed to support best practices for the challenging geometrical features.
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1.1.3 CPU Prerequisites

In order to ensure a smooth FINE™/Marine experience, it is advised to use a computer with the
following resources:

l 4GB of RAM;

l 5GB of disk space available to store all files;

l 64bits machine with 8 cores.

1.1.4 Estimated Engineering and Computing Time

Engineering time (user interaction required):

l C-Wizard automatic setup: 7minutes;

l Computation time: 8hours per speed, 24h in total;

l Post-processing: 30minutes.

1.1.5 Preparation

1. Locate and copy the file "KCS_ hull_ SVA_ cf_withnames_ cf2.x_ t" into your working
directory.

2. Start FINE™/Marine v10.2.

How to launch FINE™/Marine

l For Linux systems, you can access the FINE™/Marine v10.2 graphical user interface with the
following command line:

finemarine102 -print

l For Windows systems (Windows 7 and older), you can access the FINE™ /Marine v10.2
graphical user interface from the Start menu by going to /Programs/NUMECA
software/FineMarine102/FINE. In Windows 8 you can access it by going to the Start menu
and clicking on Search. Under Apps, there will be a section called Numeca software. Click on
FINE(#-bits) in order to open the FINE™ /Marine v10.2 graphical user interface.

Click here to start the C-Wizard setup...
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1.2 PART I - PROJECT SETUP

1.2.1 Start C-Wizard

Launching the first part of the C-Wizard plugin is performed from the FINE™/Marine interface.

1.1. Open FINE™/Marine software.

1.2. C-Wizard plugin creates its own project as a step of the project setup procedure. Select
Using the C-Wizard to launch the wizard.

When starting the C-Wizard when there is a project already opened in the FINE™/Marine interface,
a warning window will appear asking for the action to execute.

To save the ongoing project settings, select No, then save the project, go to Project > New and select
Using the C-Wizard again.

It is recommended to start the C-Wizard mode computation from the empty FINE™/Marine
interface since there will be a full-chain project setup provided. Selecting Yes in the warning will
close the opened project without saving and a new setup procedure will be started.
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1.2.2 C-Wizard Part l: Create & Set up Project

A. Create Project

2.1.1 Create a project by clicking the Create project button. In a browser define the project name
in the directory of your choice. Keep the default units.
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2.1.2 Select Resistance in the Application section and click on the Next>> button to move to the
following step of the setup. In the appearing C-Wizard window, the project setup will be
available first.
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B. Set up project: Body configuration

2.2.1 Under Input geometry : select Parasolid/CATPart and click on the Import
Parasolid/CATPart file button ('*.x_t' and '*.CATPart' formats are available here).

2.2.2 Import the previously downloaded Parasolid file KCS_hull_SVA_cf_withnames_cf2.x_t
(available in tutorials folder under \_beginner\Tutorial_3 ). When the geometry is imported,
impose the following settings:

2.2.2.1 SelectHalf body to inform the C-Wizard what the loaded configuration is.

The body and flow conditions here are symmetric, thus half of the body is used. It is also possible to
import an entire body geometry and create a half-body domain of computation. Running Half body
will speed up the computation, as the mesh size will be halved.

2.2.2.2 Under section Body orientation, activate Positive-X axis for CoG to bow and Positive-
Y axis for CoG to side.

The orientation of the X-axis is required to avoid defining negative speeds in the following entries;
Y-axis direction will help to define the domain configuration.

2.2.2.3 Select Yes under section Is the body aligned with Cartesian axis?

This question sets the Cardan angles. When Yes is selected, Cardan angles are automatically set to
zero.

2.2.2.4 Select Automatic (=LOA) under section Body reference length. The reference length
will be automatically measured by the C-Wizard and set to the Length Over All.

2.2.2.5 Select User defined and set the Z-coordinate to <9.0> under section Initial free surface
position.
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The initial free surface is defined in the geometry coordinate system. In this case Z=0 is located at the
hull bottom.

2.2.2.6 Select Automatic (based on initial free surface) under section Body mass. The body
mass will be automatically calculated based on the equilibrium position.

2.2.2.7 Select Automatic (based on initial free surface) under section Center of gravity. The
center of gravity position will be automatically calculated based on the equilibrium position.

2.2.2.8 Keep the trim set to Frozen under the Adjust pitch for hydrostatic equilibrium?
section.

2.2.2.9 Keep the Trim and Sink in a Body motion(s) to solve active.
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Click on Next>>.

C. Set up project: Flow definition

2.3.1 In the section Speed definition: activate Resistance curve. Define Vmin = 12kt, Vmax =
24kt, Speed Increment = 6kt and press Enter.

Select Successive restarts to have each computation start from the result of the previous speed.
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If the increment of speed between computations is not constant the user can directly input a list of
values separated by spaces or commas in the List of speeds field.

2.3.2 Keep deactivated the Scale input data (Froude number similarity).
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If the user would like to run this project in model scale, all inputs should be given in full scale, and the
Scaling factor set to 0.0316. The C-Wizard would then take care of scaling the geometry and all settings to
keep a Froude number similarity.

Here the calculation is performed for the full scale ship and this option should not be activated,

2.3.3 In Fluid model section: keep default properties for Air and click on the Water properties
database button to change the water properties to Salt water at 15 °C. Click on OK to validate
the new properties.

2.3.4 Click on Next>> to proceed to the additional input setup.

D. Set up project: Additional inputs

A new window with additional parameters is available here:
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2.4.1 Activate the Actuator Disk and enter the following parameters:

l Set Thickness to <1.5> [m],

l Set Inner/ Outer radius respectively to <0.5> and <2.5> [m],

l Set the Center coordinates to <5.11 0.0 4.0> [m] for X, Yand Z,
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l Set the normal to <-1.0 0 0> [m] for Dir_X, Dir_Yand Dir_Z,

l Set Thrust to <100.5> [N],

l Set Activate body self update active,

l Set Frequency of update to <5> Time steps.

When Activate body self update with Body drag is active, the thrust of the actuator disk is
automatically updated during the computation such as Thrust = Drag at a prescribed interval. The
interval corresponds to the frequency value.

2.4.2. Activate the Adaptive grid refinement on free surface, leaving the AGR setting to the
default Initial base refinement + AGR.
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2.4.3 ActivateWall roughness and choose Anti-fouling coating in the drop-down list. You can
click on Value description to get more details on the roughness values.

In full scale simulations the hull roughness will have a significant impact in the total resistance value
and it is important to define it according to the hull surface real conditions.

2.4.4 Activate Convergence checker and Convergence booster.

l Convergence checker will stop the computation when the drag and solved motions become
stable.

l Convergence booster will adapt the convergence settings during the computation to speed it
up.

2.4.5 Set the number of cores per computation to <8> under the Computation resources.

2.4.6 Click on the Next>> to proceed to the domain creation and mesh setup.
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At this step, the file wizard.input is created and saved into the computation folder next to the .iec
project file. It consists of all the inputs recorded and computed by the wizard. The switch to
HEXPRESS™ interface is performed here: C-Wizard will generate domain and mesh automatically
respecting the geometry and input parameters (body configuration, orientation, free surface position
and etc.).

Click here for the domain and meshing details...

1.3 PART I - DOMAIN & MESH SETUP

1.3.1 Mesh Setup

The last page of the C-Wizard gives the user control on the domain and mesh setup.

1.1 Set Mesh density toMedium.

Refinements on patches are applied according to their names and to the mesh density level.

The initial cell size in the mesh is defined to have a number of cells per maximum length of the
ship (Loa). For example, the number of cells per Loa for the initial mesh size is set to 3 if coarse,
4 if medium and 5 if fine.
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The refinement level assigned to a patch according to its name is defined in the refinement
dictionary.

1.2 Set Extra refinement of the wave field to No.

This option will create a refinement sector with low aspect ratio cells covering the Kelvin angle area.
It will lead to a high resolution of the wave field, but it increases the number of cells in the mesh
considerably. For the current Froude number additional refinement of the wave field is not necessary,
thus this parameter is deactivated.

1.3 For the current computational project, geometry is checked and proper names were defined in
the CADfix software.

For the C-Wizard projects Merging by name is the priority. The reason behind this choice is
that a ship hull can be generally represented by several common parts like: bow, stern, deck, hull,
appendages, etc. Once names are defined, C-Wizard will perform merging and apply mesh
parameters automatically.

Two options are available from the C-Wizard mode: Merge faces with the same name and/or
Merge tangential faces.

l SetMerge faces with the same name to Yes.

The C-Wizard reads the name of every patch and merges the ones that are adjacent and with identical
names: all patches named "Bow_1" will be merged to one patch and named "Bow_1". When preparing the
geometry, the user should give identical names to all patches that need to be merged together.

Patches named Bow_1 and Bow_2 will not be merged, but they will all get the mesh refinement settings
assigned to "Bow " in the refinement dictionary.

l KeepMerge tangential faces to No.
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This option is exactly the same as for the HEXPRESS™ (Domain Manipulation ) and when
activated it checks if the neighbor patch has a tangent angle greater than a specified one and merge if
it is greater. This method is especially helpful when the geometry imported is a Parasolid file with
big number of patches.

Each time two faces are merged, the new face gets an ID (ID's are incremented one by one). It
assigns specific values for the future mesh refinement strategy according to the name of the patch.
By default, the name will be the one which leads to the higher refinement.

1.4 Click on the Advanced>>> button to check the additional parameters.
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1.5 Keep the default domain settings: User-defined domain size not active.
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When not active, the default domain is set to 5Loa x 2Loa x 2Loa. This domain size is recommended
for resistance computations with Froude number under 0.5. For higher Froude numbers the
downstream boundary will be placed further from the hull to accommodate the longer wake.

1.6 Set Triangulation density to Fine.

1.7 Under section Y+ value select User defined and set Y+ to <220>.

1.8 Click on Start mesh set-up button to start the domain creation and the mesh setup. One can
check the shell to see the process in action.

An information window reporting that the first part of the C-wizard has been successfully finished
will appear. It also gives information about the computed Froude number and suggests the
following actions. Click Manually check the mesh first to activate the HEXPRESS™ interface
without immediately starting the mesh generation.

1.9 In HEXPRESS™ , the following parameters based on the previous inputs are imposed:

l Domain with the internal free surface is created, merging by name is performed according to
the names of patches.
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l External boundary conditions (Grid/ Boundary Conditions) of the domain are automatically
named and defined as follows.

FINE™/Marine 10.2 Tutorials21



l The mesh setup is done automatically in accordance to the previously imposed settings
(Medium density mesh). The parameters can be checked through the HEXPRESS™ Mesh
Wizard menu:

Initial mesh

2304 cells
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Adapt to geometry

• Maximum number of refinements: 12 (Global tab)
• Curve refinement:

— Curve 158: 8 ; Target Cell Size (0,0,0)
• Surface refinement:

— Deck*: 4 ; Target Cell Size (0,0,0) ; Refinement diffusion: Global ; patches automatically grouped:
"Deck1_b1", "Deck2_b1", "Deck3_b1"

— Shaft*: 8 ; Target Cell Size (0,0,0) ; Refinement diffusion: Global ; patches automatically grouped:
"Shaft_end_b1", "Shaft_b1"

— Hull_b1: 6 ; Target Cell Size (0,0,0) ; Refinement diffusion: Global
— Transom_b1: 8 ; Target Cell Size (0,0,0) ; Refinement diffusion: Global
— Bow_b1: 8 ; Target Cell Size (0,0,0) ; Refinement diffusion: Global

Global_FS: 7 ; Target cell size: (X: 74.9089, Y: 74.9089, Z: 0.0) ; Aspect Ratio 128 ; Refinement
diffusion: 3 ; Free surface has anisotropic refinement in Z-direction to provide a sufficient mesh
resolution for the wave elevation

• Box refinement:
— Sector #0: for the actuator disk zone; Refinement: 10 ; Target cell size: X=Y=Z=0.0 ; Refinement

diffusion: 3
— Sector #1: for the actuator disk wake; Refinement: 9 ; Target cell size: X=Y=Z=0.0 ; Refinement

diffusion: 3
• Trimming: all SOL patches are set to Used for trimming andMIR and EXT patches are defined as

Not used for trimming.

Snap to geometry

Buffer insertion of Type II for all edges on the Mirror plane and External boundaries edges

Optimize

Max nb of orthogonality optimization iterations: 5

Minimal orthogonality threshold: 5.0
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Viscous layer

Viscous layers are defined and computed for Solid boundaries only and if the face name does not contain
the word "deck" since there is usually no need to insert viscous layers (viscous effects from the air part
are negligible).

Fixed first layer thickness Method

Floating number of layers:

Minimum number of layers: 11

Maximum number of layers: 22

Active with First layer thickness <0.005388>

for

Shaft: 13 layers

Hull_b1: 20 layers

Transom_b1: 13 layers

Bow_b1: 13 layers

1.3.2 Mesh Generation

HEXPRESS™ includes a multi-threading capability allowing to speed up the Optimization step and
the optimization loops included inside the Viscous Layer insertion step.

To activate it, in Menu bar of HEXPRESS™: Project > Preference > Mesh generation >
Multithreading

Please refer to the HEXPRESS™ documentation for the advised number of threads.

2.1 Click the Start button in theMesh Wizard to generate the mesh.

FINE™/Marine 10.2 Tutorials24



The generated mesh looks like the picture below with around 1.2M cells.
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The quality of the mesh can be improved here by generating the Fine mesh. For the current sample
study a medium mesh is considered to be sufficient.

2.2 Once the mesh is generated, click the Go back to the project set-up button to start
FINE™/Marine GUI.

2.3 Click on Yes to save the generated mesh.

Click here to finish the setup...

1.4 PART II - FLOW SETTINGS & POST
PROCESSING

1.4.1 C-Wizard Part II: Flow Settings

A. Estimate Hydrostatic Values

1.1.1. Check the computed values.

This part of the C-Wizard will provide the Estimation of hydrostatic values for the present
study: the Displacement and Coordinates of the Center of Gravity . This part refers to the
domhydro calculations (see the FINE™/Marine user guide for more explanations on the
domhydro tool).
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1.1.2. Check the computed values and click on Next to finalize flow settings setup.

B. Flow Settings

The automated C-Wizard setup will create 3 computations :

The computation C2_ 18.000kt has the following settings. They can be checked in the
FINE™/Marine interface.

Time configuration:

Steady

Fluid model:

Salt water at 15°C/Air

Flow model:

Reference length: 243.844m

Reference velocity: 9.259929m/s

Boundary conditions:
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l SOLID

l Deck: SLIP

l all the rest SOLID:WALL FUNCTION with a sand grain height of 3e-05m.

l EXTERNAL

l Zmax, Zmin: PRESCRIBED PRESSURE, updated hydrostatic pressure

l Xmin, Xmax, Ymax: FAR FIELD

l MIRROR: Ymin_SYM

Body definition:

All the solid patches are grouped together and called "Vessel" for the body

Body motion:

Motion definition:
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l Tz0,Ry1 Solved: Free trim and sink DOF's

l Tx is imposed as ½ sinusoidal ramp profile: acceleration speed from 6.173328m/s to the final
value of 9.259992m/s

Cardan Angles activated

Quasi-Static (QS) approach activated in Hull mode.

This method is applied to relax the condition of small time step required by the coupling of the flow
motion and the Newton's law. The QS method decreases the CPU time and remain stable even for the
larger time step. This method is based on a succession of predicted body attitudes.

Dynamic parameters:
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Mesh management: default

Initial solution:

Restart from the previous computation: C1_12.000kt

Additional models:

Actuator disc activated with the settings imposed in the C-Wizard

Numerical parameters: Adaptive grid refinement

l Refinement criterion type: Free surface (tensor)

l Target grid spacing normal to free surface: 0.31967

l Criterion diffusion: 2 layers copying full criterion value and 0 for fraction of value

l Boundary layer protection: Longitudinal direction only

l Box: Directional refinement only (X,Y around the ship area and Z everywhere)

l Control

l 200 steps before the first call of refinement procedure

l 25 steps between calls to refinement procedure
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Control variables:

l The Number of time steps is set to 1200.

l The Time step value is computed based on the reference length and reference velocity:
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Convergence tab:

l Activate convergence booster is selected.

l The Convergence checker is active and will check for the drag, trim and sinkage values
oscillations to be less than 1% of their mean value to stop the computation.
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Outputs

Motion & force variables:

l Translation variables: Tx0, Tz0

l Velocity variables: Vx0, Vz0

l Acceleration variables: Ax0, Az0

l Force decomposition: Global frame

l Rotation variables: Rotation, Ry1

l Angular velocity variables: dRy1

l Angular acceleration variables: d2Ry1
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1.4.2 Launch & Control Computation

2.1. Click on Save Project icon to save the project.

2.2. Go to the Task Manager by clicking on the icon

2.3. The Computation resources options was active in the C-Wizard and now the 3
computations are prepared and queued one after the other:

2.4 The number of partitions is automatically set to the earlier specified value of <8> , or the
maximum number of cores available in the machine. Change this value if needed.
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It is not compulsory to set this number of partitions. When set to 7, the computation will take
approximately 10,5 hours on Linux 64-bit OS, Intel(R) Core(TM) i7-3370 CPU @ (3.4 GHz, 8 cores,
16 GB RAM)

2.5. Select the computation C1_12.000kt and Click on Start button to start it.

When the solver finishes the computation, the Task Manager will display the computation status
it in the TASK MANAGER INFO window and the next queued computation will start
automatically.

2.6. While the computations are running the Monitor can be used to check the evolution of
the quantities.

In the Quantities to display menu, it is possible to select the quantities (residuals, forces,
moments, motions and actuator disk variables) for which one would like to follow the
convergence history or check the computed values.

Multiple components or quantities from different runs can be displayed together as presented
below. The button Add can be used to open several computations at the same time and compare
their results.
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FIGURE 1.1
Residuals evolution

In the Residuals page, activate log scale to see the orders of magnitude the residuals have
decreased. And set the minimum Iterations value to remove initial peaks. The residuals by
themselves do not give us enough information to check convergence, forces and solved motions
should also be checked for stability.

FIGURE 1.2
Drag evolution and averaged value on the last 10% of each computation
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The Draw average of last X% option should be used over a stable part of the computation to
obtain average results and avoid taking the value of a single time step. The Results analyis tool
will be presented in the next section with more post-processing options.

FIGURE 1.3
Trim angle (Ry) evolution in the three computations

The angle units can be switched beteen radians or degrees.
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FIGURE 1.4
Actuator disk thrust

In this case the thrust of the actuator disk matches the drag of the hull. Note that the force value is
given for half the geometry, while the actuator disk thrust is given for the full disk.

1.4.3 Post Processing

A. Results analysis tool

Once the three computations have finished, select them under the list of computations and start the

results analysis tool by clicking on the icon .
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3.1.1 Activate Perform resistance curve

3.1.2 In specific quantities select Fx (total drag), FxV (viscous drag), FxP (pressure drag), Fz and
the solved motions Tz0 (sinkage) and Ry1 (trim angle).

3.1.3 Under Other quantities select Number of cells, Actuator disk thrust and torque and Wetted
surface area.
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3.1.4 In Analysis options activate the options shown in the image:

l Average efforts and motions over the last 10% with a Convergence criterion of 1%. In the
plots a green dotted line will be shown where this condition is first met: the amplitude of
oscillation of the signal remains below 1% of the average during 10% of the computed time.

The convergence is checked separately for each quantity selected: some quantities will
stabilize very quicly while others might not reach this level of convergence.

l Draw average line

l Draw convergence line

l Apply a Moving average with a window of 5 time steps to efforts and motions to display a
smooth signal.
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3.1.5 In Plot options select

l Double the drag Fx for a half body simulation to obtain plots with the complete hull drag.

l Use absolute values to have plots showing drag as a positive value.

l Change the angle unit to Degrees.
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3.1.6 Click on Perform to run the analysis. It will create a new folder in the computation directory
named Convergence_report_<date>_<time>.

On this folder the user will find the plots of all selected quantities versus Froude number.
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FIGURE 1.5
Drag vs Froude number plot.
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FIGURE 1.6
Trim angle vs. Froude number plot.

Inside the global folder, a folder per computation is created. In this sub-folders, like C1_12.000kt,
the file computed_data.dat is saved. It contains the averaged values for each quantity and the
time and number of time steps needed to reach convergence for each quantity. Besides, the plots
of each quantity evolution during the computation are stored.
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FIGURE 1.7
Evolution of drag during the 12kt computation (blue), average value over the last 10% of time

steps (black) and point where convergence for drag was reached (green).
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FIGURE 1.8
Evolution of the number of cells in the mesh due to Adaptive grid refinement in the 12kt

computation.

B. CFView™

3.2.1. To start the Post-processing, click on the CFView icon of the FINE™/Marine toolbar.

3.2.2. In the appearing selection menu, keep the Traveling shot based on Vessel and activate
Tx0 to open. This way the post-processing "camera" will remain centered on the ship. Click the
Ok button.
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3.2.3 Once in CFView, use the Open button to load the other two computation's results. The .cfv
file in each computation folder needs to be selected.

3.2.4 UseWindow > Tile Views to show the three computations results at the same time.

3.2.5 Click on one view to select it (the view frame will be highlighted in red) and use View >
Maximize if at some point during the next steps you want to work on only one result.

In the current tutorial, the free surface, hydrodynamic pressure and wake flow parameters are
chosen for the visualization.

The following steps should be performed on each result:

3.2.6 Mirror the results with Shift+R . This option is also available in Geometry > Repetition
on/off.

3.2.7 Solid body rendering:

l UseMacros > Group patches by type and select the Solid patches group

l Remove the boundary edges and activate solid rendering. UnderMaterial, open the menu and
change the rendering color to a lighter gray. Lower the solid opacity to 70%.
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3.2.8 Free surface representation:

l UseMacros > Represent free surface

l Use the Set range button to set the same range from 7.7 to 11.8 in all results. Press Enter
to apply it.
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l To apply the same view in all results, activate one view, click on the = key and select the
reference view.

l When all views are ready go to File > Print to save images. Select Active View to save only
one result image or Graphics Window to save the three results image. Deactivate Frame and
adjust the Quality value depending on the image's purpose.

l All steps performed can be recovered as python macros in File >Macro > Save All. This can
become useful to automate post-processing when you gain experience with the program.
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l Press Ctrl+d or go to Update > Delete > All to restore each view to its initial clean state.

3.2.9 To represent the hydrodynamic pressure, the steps to perform are:

l select all Solid patches on the Surfaces menu,

l selectHydrodynamic pressure in Quantities,

l click on in the Contours & Iso Values.

l Change the colormap with: Update > Colormap >Matlab style > Reset jet
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3.2.10 The next step will be using the Wake flow tool to visualize the velocity field in the
propeller location.

l Use orWindow > Close to close all views except the 24kt result.

l Select theMacros > Wake_flow_tool.

As an Actuator diskwas activated in the C-Wizard setup, the tool proposes the disk location by
default

l Keep these values and press Go.
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l The tool will recompute the flow field in a cylindrical cut and open three new views with the
axial, radial and tangential flow components.

l The information is also stored in the file wake_flow.txt in the computation folder.
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